kerberos authentication with neon 0.29.3

Kravzov Amit Aharon amitkar at rafael.co.il
Thu Mar 11 07:53:29 EST 2010


Hi,

I get the following error from TortoiseSVN 1.6.7 (neon 0.29.3) when trying to perform any CM action: "PROPFIND of /Fqa/test authorisation failed.could not authenticate to
server.could not parse challenge https://server"
and by looking on the server access log we can see that there is no
passing of a ticket to the apache server.
>> > 192.168.223.129 - - [22/Feb/2010:09:20:31 +0100] "PROPFIND /svn/ProjectName/branches HTTP/1.1" 401 394 "-" "SVN/1.6.9 (r901367)/TortoiseSV​​N-1.6.7.18415​ neon/0.29.3"

TortoiseSVN 1.6.6 (neon 0.28.6) works fine.

Moreover, I get the following error from ALL VERSIONS of AnkhSVN 2.1 (neon 0.29.3) when trying to perform any CM action from VisualStudio 2010 (since AnkhSVN 2.0 does not integrate with VisualStudio 2010): "You failed to authorize against the remote repository"

AnkhSVN 2.0 (specific version I have is 2.0.6347.443, with neon 0.28.3) works fine.
AnkhSVN 2.1 (neon 0.29.3) doesn't work with VisualStudio 2005,2008,2010.

Hope this is more detailed.

Thanks,
Amit.

-----------------------------------------------------------------------------

-----Original Message-----
From: Joe Orton [mailto:jorton at manyfish.co.uk] On Behalf Of Joe Orton
Sent: Thursday, March 11, 2010 12:40 PM
To: Kravzov Amit Aharon
Cc: 'neon at lists.manyfish.co.uk'; KATZIR MALKA LIAT
Subject: Re: kerberos authentication with neon 0.29.3


On Thu, Mar 11, 2010 at 09:15:08AM +0200, Kravzov Amit Aharon wrote:
> I'm using 2 svn clients: AnkhSVN and TortoiseSVN, which both of them
> use neon. AnkhSVN 2.1 & TortoiseSVN 1.6.7 are compiled with neon
> 0.29.3 and both of them have problems to authenticate against a
> repostory with kerberos authentication. TortoiseSVN support says they
> didn't do anything to avoid authentication with kerberos and it might
> result from switching neon to 0.29.3.

Hi.  You need to be more specific about the "problems" you are seeing for anybody to be able to help you.  What errors are you seeing on the client?  Did use of a previous version of neon work?  I'm not aware of any specific regressions in 0.29.x.

Regards, Joe

**********************************************************************************************
This message (including any attachments) issued by RAFAEL- ADVANCED DEFENSE SYSTEMS LTD. 
(hereinafter "RAFAEL") contains confidential information intended for a specific individual and purpose, may 
constitute information that is privileged or confidential or otherwise protected from disclosure. If you are not 
the intended recipient, you should contact us immediately and thereafter delete this message from your 
system. You are hereby notified that any disclosure, copying, dissemination, distribution or forwarding of this 
message, or the taking of any action based on it, is strictly prohibited. If you have received this e-mail in error, 
please notify us immediately by e-mail mailto:lawraf at rafael.co.il and completely delete or destroy any and all 
electronic or other copies of the original message and any attachments thereof.
**********************************************************************************************


More information about the neon mailing list