neon v0.29.6 compilation problems

Laszlo Boszormenyi gcs at debian.hu
Mon Jun 13 08:16:29 EDT 2011


Hi,

Trying to build neon v0.29.6 fails. The SSL flavor fails with:
/bin/bash ../libtool --silent --mode=link gcc  -no-install -o uri-tests uri-tests.lo libtest.la
neon-openssl/src/.libs/libneon.so: undefined reference to `SSLv2_server_method'
collect2: ld returned 1 exit status

Indeed, SSLv2 support got disabled[1] in openssl v1.0.0 . Would neon
still use it or drop its usage?

The second is that gnutls_certificate_verify_peers() also marked
deprecated[2][3] in GnuTLS 2.12 and will be removed with the new major
release. Upstream notes that gnutls_certificate_verify_peers2() should
be used from now on.

Should I wait for a new neon release or would you commit changes for
these issues?

Regards,
Laszlo/GCS
[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622140
[2] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624086
[3] http://lists.gnu.org/archive/html/help-gnutls/2011-03/msg00011.html




More information about the neon mailing list