[PATCH] Fix ne_pkcs11.c compatibility with OpenSSL 1.1

Joe Orton joe at manyfish.co.uk
Tue Dec 24 05:35:54 EST 2019


On Sat, Feb 23, 2019 at 05:42:20AM +0100, Arfrever Frehtes Taifersar Arahesis wrote:
> Revision r1974 added some code in src/ne_pkcs11.c for compatibility with OpenSSL 1.1,
> but it contains small mistake:
> 
> +#if defined(RSA_F_RSA_PRIVATE_ENCRYPT)
> +#define PK11_RSA_ERR (RSA_F_RSA_PRIVATE_ENCRYPT)
> +#else
>  #define PK11_RSA_ERR (RSA_F_RSA_EAY_PRIVATE_ENCRYPT)
> +#endif
> 
> In OpenSSL 1.1, RSA_F_RSA_EAY_PRIVATE_ENCRYPT has been actually renamed to
> RSA_F_RSA_OSSL_PRIVATE_ENCRYPT, not RSA_F_RSA_PRIVATE_ENCRYPT.

Thanks Arfrever, pushed to git.

https://github.com/notroj/neon/commit/943fdea78fd3d293841e151783e7ecbbd2c39035

Regards, Joe




More information about the neon mailing list